import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "`([a-z]\\w)*`.+auto_increment[\\s\\S]+";
final String string = "`id` INT (11) UNSIGNED NOT NULL AUTO_INCREMENT COMMENT 'primary',\n"
+ "`stu_name` VARCHAR (10) NOT NULL DEFAULT '' COMMENT 'username',\n"
+ "`stu_class` VARCHAR (10) NOT NULL DEFAULT '' COMMENT 'class',\n"
+ "`stu_num` INT (11) NOT NULL DEFAULT '0' COMMENT 'study number',\n"
+ "`stu_score` SMALLINT UNSIGNED NOT NULL DEFAULT '0' COMMENT 'total',\n"
+ "`tuition` DECIMAL (5, 2) NOT NULL DEFAULT '0' COMMENT 'fee',\n"
+ "`phone_number` VARCHAR (20) NOT NULL DEFAULT '0' COMMENT 'mobile',\n"
+ "`create_time` TIMESTAMP NOT NULL DEFAULT CURRENT_TIMESTAMP COMMENT 'record created time',\n"
+ "`update_time` TIMESTAMP NOT NULL DEFAULT CURRENT_TIMESTAMP COMMENT 'record updated time',\n"
+ "`status` TINYINT NOT NULL DEFAULT '1' COMMENT 'some comment',";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}