# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"`([a-z]\w)*`.+auto_increment[\s\S]+"
test_str = ("`id` INT (11) UNSIGNED NOT NULL AUTO_INCREMENT COMMENT 'primary',\n"
"`stu_name` VARCHAR (10) NOT NULL DEFAULT '' COMMENT 'username',\n"
"`stu_class` VARCHAR (10) NOT NULL DEFAULT '' COMMENT 'class',\n"
"`stu_num` INT (11) NOT NULL DEFAULT '0' COMMENT 'study number',\n"
"`stu_score` SMALLINT UNSIGNED NOT NULL DEFAULT '0' COMMENT 'total',\n"
"`tuition` DECIMAL (5, 2) NOT NULL DEFAULT '0' COMMENT 'fee',\n"
"`phone_number` VARCHAR (20) NOT NULL DEFAULT '0' COMMENT 'mobile',\n"
"`create_time` TIMESTAMP NOT NULL DEFAULT CURRENT_TIMESTAMP COMMENT 'record created time',\n"
"`update_time` TIMESTAMP NOT NULL DEFAULT CURRENT_TIMESTAMP COMMENT 'record updated time',\n"
"`status` TINYINT NOT NULL DEFAULT '1' COMMENT 'some comment',")
subst = "\\1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.