$re = '/^.*\n(.*?)\n.*/m';
$str = 'Какие-то слова:
Слова которые нужно достать 123
ещё какие-то слова
ещё
и ещё';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);