re = /^.*\n(.*?)\n.*/m
str = 'Какие-то слова:
Слова которые нужно достать 123
ещё какие-то слова
ещё
и ещё'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end