package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(#\S+(?:\s+[^\s="]+="[^"]+")+),(.*)\s*(.*)`)
var str = `#EXTINF:-1 tvg-id="ChannelName" tvg-name="|FR| Channel" tvg-logo="http://logo" timeshift="1" group-title="|FR| FrenchChannel",|FR| Channel Fullname
URL`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}