// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^(#\S+(?:\s+[^\s="]+="[^"]+")+),(.*)\s*(.*)"#).unwrap();
let string = "#EXTINF:-1 tvg-id=\"ChannelName\" tvg-name=\"|FR| Channel\" tvg-logo=\"http://logo\" timeshift=\"1\" group-title=\"|FR| FrenchChannel\",|FR| Channel Fullname
URL";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}