re = /^(#\S+(?:\s+[^\s="]+="[^"]+")+),(.*)\s*(.*)/m
str = '#EXTINF:-1 tvg-id="ChannelName" tvg-name="|FR| Channel" tvg-logo="http://logo" timeshift="1" group-title="|FR| FrenchChannel",|FR| Channel Fullname
URL'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end