#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "([^\|]*\|){7}"
Local $sString = "aaa|bbb|ccc|234| | f5h | |tgvsfj| jhsfj| | | | 6384;" & @CRLF & _
"aaa|ggg|hhh|56f| | 563 | |dhr| jhsfj| | | | 6385;"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")