using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\|]*\|){7}";
string input = @"aaa|bbb|ccc|234| | f5h | |tgvsfj| jhsfj| | | | 6384;
aaa|ggg|hhh|56f| | 563 | |dhr| jhsfj| | | | 6385;";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}