// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([^\|]*\|){7}").unwrap();
let string = "aaa|bbb|ccc|234| | f5h | |tgvsfj| jhsfj| | | | 6384;
aaa|ggg|hhh|56f| | 563 | |dhr| jhsfj| | | | 6385;";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}