#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\.0*([^0])|^([^0])"
Local $sString = "0.18" & @CRLF & _
"0.004" & @CRLF & _
"0.01920" & @CRLF & _
"0.000000000000086351" & @CRLF & _
"0.90000000" & @CRLF & _
"815805" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"50" & @CRLF & _
"5000" & @CRLF & _
"180843" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")