package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.0*([^0])|^([^0])`)
var str = `0.18
0.004
0.01920
0.000000000000086351
0.90000000
815805
1
2
50
5000
180843
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}