using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^<HOST>.*POST .*.(*wp-login\.php|*xmlrpc\.php).*.(403|499)*";
string input = @"06/Oct/2016:18:44:29 +0200 191.96.249.53 - - mydomain.com ""POST /xmlrpc.php HTTP/1.0"" 499 0 ""-"" ""Mozilla/4.0 (compatible: MSIE 7.0; Windows NT 6.0)"" ""-""
06/Oct/2016:18:44:29 +0200 191.96.249.53 - - mydomain.com ""POST /xmlrpc.php HTTP/1.0"" 499 0 ""-"" ""Mozilla/4.0 (compatible: MSIE 7.0; Windows NT 6.0)"" ""-""
06/Oct/2016:18:44:29 +0200 191.96.249.53 - - mydomain.com ""POST /xmlrpc.php HTTP/1.0"" 499 0 ""-"" ""Mozilla/4.0 (compatible: MSIE 7.0; Windows NT 6.0)"" ""-""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}