# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^<HOST>.*POST .*.(*wp-login\.php|*xmlrpc\.php).*.(403|499)*"
test_str = ("06/Oct/2016:18:44:29 +0200 191.96.249.53 - - mydomain.com \"POST /xmlrpc.php HTTP/1.0\" 499 0 \"-\" \"Mozilla/4.0 (compatible: MSIE 7.0; Windows NT 6.0)\" \"-\"\n"
"06/Oct/2016:18:44:29 +0200 191.96.249.53 - - mydomain.com \"POST /xmlrpc.php HTTP/1.0\" 499 0 \"-\" \"Mozilla/4.0 (compatible: MSIE 7.0; Windows NT 6.0)\" \"-\"\n"
"06/Oct/2016:18:44:29 +0200 191.96.249.53 - - mydomain.com \"POST /xmlrpc.php HTTP/1.0\" 499 0 \"-\" \"Mozilla/4.0 (compatible: MSIE 7.0; Windows NT 6.0)\" \"-\"")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.