// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^<HOST>.*POST .*.(*wp-login\.php|*xmlrpc\.php).*.(403|499)*").unwrap();
let string = "06/Oct/2016:18:44:29 +0200 191.96.249.53 - - mydomain.com \"POST /xmlrpc.php HTTP/1.0\" 499 0 \"-\" \"Mozilla/4.0 (compatible: MSIE 7.0; Windows NT 6.0)\" \"-\"
06/Oct/2016:18:44:29 +0200 191.96.249.53 - - mydomain.com \"POST /xmlrpc.php HTTP/1.0\" 499 0 \"-\" \"Mozilla/4.0 (compatible: MSIE 7.0; Windows NT 6.0)\" \"-\"
06/Oct/2016:18:44:29 +0200 191.96.249.53 - - mydomain.com \"POST /xmlrpc.php HTTP/1.0\" 499 0 \"-\" \"Mozilla/4.0 (compatible: MSIE 7.0; Windows NT 6.0)\" \"-\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}