# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:-|\G(?!^))\K\w/*/gm;t' <<< "asd-wqe ffvrf
asd-ss sd
a-word
a-verylongword
an-extremelyverylongword"