import Foundation
let pattern = #"(?:-|\G(?!^))\K\w"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
asd-wqe ffvrf
asd-ss sd
a-word
a-verylongword
an-extremelyverylongword
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"*"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)