const regex = /(?:-|\G(?!^))\K\w/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:-|\\G(?!^))\\K\\w', 'gm')
const str = `asd-wqe ffvrf
asd-ss sd
a-word
a-verylongword
an-extremelyverylongword`;
const subst = `*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);