#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Restoration Coder: )([a-zA-Z.\s]+)([\d.,]+)"
Local $sString = "Restoration Coder: Mr. Vivek Patel 203.75 203.75" & @CRLF & _
"Attn: Mr. Rod Smallwood (WO# 21541416)" & @CRLF & _
"e/o Sod Repairs (Sinkage, Immediate Response)" & @CRLF & _
"74 Stuart St. (StOLItTville)" & @CRLF & _
"Restoration Coder: Mr. Vivek roy 267.11 267.11" & @CRLF & _
"Attn: Mr. Rod Smallwood (WO# 24021301)" & @CRLF & _
"cx’o Sod Repairs (Removal ofspoils? Topsoila‘Seeding)" & @CRLF & _
"75 George St (Aurora)" & @CRLF & _
"Restoration Coder: Mr. arin Patel 251.85 251.85" & @CRLF & _
"Attn: Mr. Rod Smallwood (WO# 23512606)" & @CRLF & _
"010 Interlocking Brick Repairs" & @CRLF & _
"143 Spruce St (Aurora)" & @CRLF & _
"Restoration Coder: Mr. arin Patel 25185 251.85" & @CRLF & _
"Attn: Mr. Rod Smallwood (WO# 23512606)" & @CRLF & _
"010 Interlocking Brick Repairs" & @CRLF & _
"143 Spruce St (Aurora)" & @CRLF & _
"Restoration Coder: Mr. arin Patel 2,185.00 251.85" & @CRLF & _
"Attn: Mr. Rod Smallwood (WO# 23512606)" & @CRLF & _
"010 Interlocking Brick Repairs" & @CRLF & _
"143 Spruce St (Aurora)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")