use strict;
my $str = 'Restoration Coder: Mr. Vivek Patel 203.75 203.75
Attn: Mr. Rod Smallwood (WO# 21541416)
e/o Sod Repairs (Sinkage, Immediate Response)
74 Stuart St. (StOLItTville)
Restoration Coder: Mr. Vivek roy 267.11 267.11
Attn: Mr. Rod Smallwood (WO# 24021301)
cx’o Sod Repairs (Removal ofspoils? Topsoila‘Seeding)
75 George St (Aurora)
Restoration Coder: Mr. arin Patel 251.85 251.85
Attn: Mr. Rod Smallwood (WO# 23512606)
010 Interlocking Brick Repairs
143 Spruce St (Aurora)
Restoration Coder: Mr. arin Patel 25185 251.85
Attn: Mr. Rod Smallwood (WO# 23512606)
010 Interlocking Brick Repairs
143 Spruce St (Aurora)
Restoration Coder: Mr. arin Patel 2,185.00 251.85
Attn: Mr. Rod Smallwood (WO# 23512606)
010 Interlocking Brick Repairs
143 Spruce St (Aurora)';
my $regex = qr/(?<=Restoration Coder: )([a-zA-Z.\s]+)([\d.,]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}