import Foundation
let pattern = #"(?<=Restoration Coder: )([a-zA-Z.\s]+)([\d.,]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
Restoration Coder: Mr. Vivek Patel 203.75 203.75
Attn: Mr. Rod Smallwood (WO# 21541416)
e/o Sod Repairs (Sinkage, Immediate Response)
74 Stuart St. (StOLItTville)
Restoration Coder: Mr. Vivek roy 267.11 267.11
Attn: Mr. Rod Smallwood (WO# 24021301)
cx’o Sod Repairs (Removal ofspoils? Topsoila‘Seeding)
75 George St (Aurora)
Restoration Coder: Mr. arin Patel 251.85 251.85
Attn: Mr. Rod Smallwood (WO# 23512606)
010 Interlocking Brick Repairs
143 Spruce St (Aurora)
Restoration Coder: Mr. arin Patel 25185 251.85
Attn: Mr. Rod Smallwood (WO# 23512606)
010 Interlocking Brick Repairs
143 Spruce St (Aurora)
Restoration Coder: Mr. arin Patel 2,185.00 251.85
Attn: Mr. Rod Smallwood (WO# 23512606)
010 Interlocking Brick Repairs
143 Spruce St (Aurora)
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)