import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[file](((http[s]?:\\/\\/)?[^\\s([\"<,>]*\\.[^\\s[\",><]*+))\\[\\/file]";
final String string = "halo kamu\n"
+ "[file]ini text bukan file[/file]\n"
+ "[file]http://cdn.elevenia.co.id/g/6/0/2/3/8/1/15602381_B_V2.jpg[/file]";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}