$re = '/\[file](((http[s]?:\/\/)?[^\s(["<,>]*\.[^\s[",><]*+))\[\/file]/';
$str = 'halo kamu
[file]ini text bukan file[/file]
[file]http://cdn.elevenia.co.id/g/6/0/2/3/8/1/15602381_B_V2.jpg[/file]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);