import re
regex = re.compile(r"\[file](((http[s]?:\/\/)?[^\s([\"<,>]*\.[^\s[\",><]*+))\[\/file]")
test_str = ("halo kamu\n"
"[file]ini text bukan file[/file]\n"
"[file]http://cdn.elevenia.co.id/g/6/0/2/3/8/1/15602381_B_V2.jpg[/file]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")