import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([-+]?[0-9]+[.,])(([0-9]+|[0-9]*[eE][-+]?[0-9]+))?|([-+]?[0-9]+)([.,]([0-9]+|[0-9]*[eE][-+]?[0-9]+))?)$";
final String string = "12.12\n"
+ ".12\n"
+ ".12e12\n"
+ "12.e12\n"
+ "12.12e12\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}