$re = '/^(([-+]?[0-9]+[.,])(([0-9]+|[0-9]*[eE][-+]?[0-9]+))?|([-+]?[0-9]+)([.,]([0-9]+|[0-9]*[eE][-+]?[0-9]+))?)$/m';
$str = '12.12
.12
.12e12
12.e12
12.12e12
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);