re = /^(([-+]?[0-9]+[.,])(([0-9]+|[0-9]*[eE][-+]?[0-9]+))?|([-+]?[0-9]+)([.,]([0-9]+|[0-9]*[eE][-+]?[0-9]+))?)$/m
str = '12.12
.12
.12e12
12.e12
12.12e12
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end