const regex = /(?<han>\p{Han}+)|(?<alpha>[a-z\d$asalpha]+)|(?<other>[^\p{Han}a-z\d$asalpha\s]+)/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<han>\\p{Han}+)|(?<alpha>[a-z\\d$asalpha]+)|(?<other>[^\\p{Han}a-z\\d$asalpha\\s]+)', 'gmu')
const str = `不不不,我是学生
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}