// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mu)(?<han>\p{Han}+)|(?<alpha>[a-z\d$asalpha]+)|(?<other>[^\p{Han}a-z\d$asalpha\s]+)").unwrap();
let string = "不不不,我是学生
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}