re = /(?<han>\p{Han}+)|(?<alpha>[a-z\d$asalpha]+)|(?<other>[^\p{Han}a-z\d$asalpha\s]+)/m
str = '不不不,我是学生
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end