#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=")[a-zA-Z0-9_ ]+(?<!")|""[a-zA-Z0-9_ ]+""|\w+"
Local $sString = "column1,column2,column3,column4,column5,column6" & @CRLF & _
"123,"some text",""column3 text"",""still column3 text"",4,234,""" & @CRLF & _
"123,"some text",""column3 text"",4,234,""" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")