using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<="")[a-zA-Z0-9_ ]+(?<!"")|""[a-zA-Z0-9_ ]+""|\w+";
string input = @"column1,column2,column3,column4,column5,column6
123,""some text"",""column3 text"",""still column3 text"",4,234,""
123,""some text"",""column3 text"",4,234,""
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}