$re = '/(?<=")[a-zA-Z0-9_ ]+(?<!")|""[a-zA-Z0-9_ ]+""|\w+/m';
$str = 'column1,column2,column3,column4,column5,column6
123,"some text",""column3 text"",""still column3 text"",4,234,""
123,"some text",""column3 text"",4,234,""
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);