package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(Charge Tip).*?(-V)`)
var str = `Lorem ipsum dolor sit -V amet, consectetuer adipiscing elit.
Aenean commodo ligula Charge Tip eget dolor. Aenean massa.
Cum sociis natoque penatibus et magnis dis parturient montes.
Nascetur ridiculus Charge Tip mus. Donec quam felis,-Vultricies nec.
Pellentesque eu, pretium quis, sem. Nulla consequat massa.
Quis enim. DonecCharge Tippede justo, fringilla vel, aliquet nec.-V
Vulputate eget, arcu. In enim justo, rhoncus ut.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}