# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(Charge Tip).*?(-V)"
test_str = ("Lorem ipsum dolor sit -V amet, consectetuer adipiscing elit. \n"
"Aenean commodo ligula Charge Tip eget dolor. Aenean massa. \n"
"Cum sociis natoque penatibus et magnis dis parturient montes.\n"
"Nascetur ridiculus Charge Tip mus. Donec quam felis,-Vultricies nec.\n"
"Pellentesque eu, pretium quis, sem. Nulla consequat massa.\n"
"Quis enim. DonecCharge Tippede justo, fringilla vel, aliquet nec.-V\n"
"Vulputate eget, arcu. In enim justo, rhoncus ut.")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.