import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Charge Tip).*?(-V)";
final String string = "Lorem ipsum dolor sit -V amet, consectetuer adipiscing elit. \n"
+ "Aenean commodo ligula Charge Tip eget dolor. Aenean massa. \n"
+ "Cum sociis natoque penatibus et magnis dis parturient montes.\n"
+ "Nascetur ridiculus Charge Tip mus. Donec quam felis,-Vultricies nec.\n"
+ "Pellentesque eu, pretium quis, sem. Nulla consequat massa.\n"
+ "Quis enim. DonecCharge Tippede justo, fringilla vel, aliquet nec.-V\n"
+ "Vulputate eget, arcu. In enim justo, rhoncus ut.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}