# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^((?:(?:(?!")[^|\r\n]*|"[^"\r\n]*"(?=$|\|))(?:$|\|))*+)(")/$1\\$2/gm;t' <<< "123|110092|ACCT|\"HC Account\"|\"Account1||||||||||||\"Mary\"|||\"|\"||||132|\"STE|504\"|1253|Unspecified Account|||N||ACTV|Active||||04/30/2013|12/31/2099|||||||||||||
123|110092|ACCT|\"HC Account\"|\\"Account1||||||||||||\"Mary\"|||\"|\"||||132|\"STE|504\"|1253|Unspecified Account|||N||ACTV|Active||||04/30/2013|12/31/2099|||||||||||||
123|110092|ACCT|\"HC Account\"|\"Account1||||||||||||\"|Mary\"|||\"|\"||||132|\"STE|504\"|1253|Unspecified Account|||N||ACTV|Active||||04/30/2013|12/31/2099|||||||||||||
123|110092|ACCT|\"HC Account\"|\"Account1||||||||||||\"Mary|\"|||\"|\"||||132|\"STE|504\"|1253|Unspecified Account|||N||ACTV|Active||||04/30/2013|12/31/2099|||||||||||||"