import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?:(?:(?!\")[^|\\r\\n]*|\"[^\"\\r\\n]*\"(?=$|\\|))(?:$|\\|))*+)(\")";
final String string = "123|110092|ACCT|\"HC Account\"|\"Account1||||||||||||\"Mary\"|||\"|\"||||132|\"STE|504\"|1253|Unspecified Account|||N||ACTV|Active||||04/30/2013|12/31/2099|||||||||||||\n"
+ "123|110092|ACCT|\"HC Account\"|\\\"Account1||||||||||||\"Mary\"|||\"|\"||||132|\"STE|504\"|1253|Unspecified Account|||N||ACTV|Active||||04/30/2013|12/31/2099|||||||||||||\n"
+ "123|110092|ACCT|\"HC Account\"|\"Account1||||||||||||\"|Mary\"|||\"|\"||||132|\"STE|504\"|1253|Unspecified Account|||N||ACTV|Active||||04/30/2013|12/31/2099|||||||||||||\n"
+ "123|110092|ACCT|\"HC Account\"|\"Account1||||||||||||\"Mary|\"|||\"|\"||||132|\"STE|504\"|1253|Unspecified Account|||N||ACTV|Active||||04/30/2013|12/31/2099|||||||||||||";
final String subst = "$1\\\\$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}