#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)select\s+(\*|((\w+(\.\w+)?)+(\s?,\s?\w+(\.\w+)?)*)|((\w+\([^\s]|(\w+\.\w+)?\))(\s+\,\s+)?)+)\s+from\s+(\w+(\s?,\s?\w+)*\;?)(\s+((\w+\s+join)\s+(\w+(\.\w)?\s+on\s+(\w+(\.\w+)?\s+=\s+\w+(\.\w+)?)?)(\s+,\s+)?)+)?(\s+((limit\s+(\w+)?\s?(\,\w+\;)?)|((where)?\s+?([^\;]+\s?;))))?"
Local $sString = "select * from table4;" & @CRLF & _
"select * from table4,table5;" & @CRLF & _
"select table4.id from table4,table5;" & @CRLF & _
"select table4.id from table4,table5 where table4.id=table5.id;" & @CRLF & _
"select * from table4,table5 where table4.id=table5.id;" & @CRLF & _
"select * from table4,table5 where table4.id=table5.id and table4.id => 1 ;" & @CRLF & _
"select table4.id,table5.name from table4,table5 where table4.id=table5.id and table4.id>1 ;" & @CRLF & _
"select table4.id from table4,table5 where table4.id=table5.id like %ll%;" & @CRLF & _
"select table4.id from table4,table5 where table4.id=table5.id limit 1,10;" & @CRLF & _
"select table4.id from table4,table5 limit 1,10;" & @CRLF & _
"select table4.id from table4,table5 limit 1 ;" & @CRLF & _
"select table4.id from table4,table5 where id <> 1 limit 1 ;" & @CRLF & _
"select count(*) from table4,table5 where id <> 1 limit 1 ;" & @CRLF & _
"select count(*) from table4,table5 where id <> 1 having dd group by dd ;" & @CRLF & _
"select count(*) , max(table4.id) from table4,table5 where id <> 1 having dd group by dd ;" & @CRLF & _
"select * from tab1 left join tab2 on tab1.size = tab2.size where tab2.name = AAA;" & @CRLF & _
"select * from tab1 left join tab2 on tab1.size = tab2.size , right join tab2 on tab1.size = tab2.size where tab2.name = AAA and dd = dd;" & @CRLF & _
"select count(*) , max(table4.id) from table4,table5 left join tab2 on tab1.size = tab2.size , right join tab2 on tab1.size = tab2.size where id <> 1 having dd group by dd ;" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")