# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"select\s+(\*|((\w+(\.\w+)?)+(\s?,\s?\w+(\.\w+)?)*)|((\w+\([^\s]|(\w+\.\w+)?\))(\s+\,\s+)?)+)\s+from\s+(\w+(\s?,\s?\w+)*\;?)(\s+((\w+\s+join)\s+(\w+(\.\w)?\s+on\s+(\w+(\.\w+)?\s+=\s+\w+(\.\w+)?)?)(\s+,\s+)?)+)?(\s+((limit\s+(\w+)?\s?(\,\w+\;)?)|((where)?\s+?([^\;]+\s?;))))?"
test_str = ("select * from table4;\n"
"select * from table4,table5;\n"
"select table4.id from table4,table5;\n"
"select table4.id from table4,table5 where table4.id=table5.id;\n"
"select * from table4,table5 where table4.id=table5.id;\n"
"select * from table4,table5 where table4.id=table5.id and table4.id => 1 ;\n"
"select table4.id,table5.name from table4,table5 where table4.id=table5.id and table4.id>1 ;\n"
"select table4.id from table4,table5 where table4.id=table5.id like %ll%;\n"
"select table4.id from table4,table5 where table4.id=table5.id limit 1,10;\n"
"select table4.id from table4,table5 limit 1,10;\n"
"select table4.id from table4,table5 limit 1 ;\n"
"select table4.id from table4,table5 where id <> 1 limit 1 ;\n"
"select count(*) from table4,table5 where id <> 1 limit 1 ;\n"
"select count(*) from table4,table5 where id <> 1 having dd group by dd ;\n"
"select count(*) , max(table4.id) from table4,table5 where id <> 1 having dd group by dd ;\n"
"select * from tab1 left join tab2 on tab1.size = tab2.size where tab2.name = AAA;\n"
"select * from tab1 left join tab2 on tab1.size = tab2.size , right join tab2 on tab1.size = tab2.size where tab2.name = AAA and dd = dd;\n"
"select count(*) , max(table4.id) from table4,table5 left join tab2 on tab1.size = tab2.size , right join tab2 on tab1.size = tab2.size where id <> 1 having dd group by dd ;\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.