import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:|(?:0|[1-9][0-9]{0,1}|1[0-9]{2}|2[0-4][0-9]|25[0-5])(?:(?:\\.(?:0|[1-9][0-9]{0,1}|1[0-9]{2}|2[0-4][0-9]|25[0-5])){0,2}\\.?|(?:\\.(?:0|[1-9][0-9]{0,1}|1[0-9]{2}|2[0-4][0-9]|25[0-5])){0,3}))$";
final String string = "\n"
+ "0\n"
+ "0.\n"
+ "0.0\n"
+ "0.0.\n"
+ "0.0.0\n"
+ "0.0.0.\n"
+ "0.0.0.0\n"
+ "0.0.0.0.\n"
+ "0.0.0.0.0\n\n"
+ "255.255.255.255\n"
+ "256.0.0.0\n"
+ "0.256";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}