$re = '/^(?:|(?:0|[1-9][0-9]{0,1}|1[0-9]{2}|2[0-4][0-9]|25[0-5])(?:(?:\.(?:0|[1-9][0-9]{0,1}|1[0-9]{2}|2[0-4][0-9]|25[0-5])){0,2}\.?|(?:\.(?:0|[1-9][0-9]{0,1}|1[0-9]{2}|2[0-4][0-9]|25[0-5])){0,3}))$/m';
$str = '
0
0.
0.0
0.0.
0.0.0
0.0.0.
0.0.0.0
0.0.0.0.
0.0.0.0.0
255.255.255.255
256.0.0.0
0.256';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);