const regex = /^(?:|(?:0|[1-9][0-9]{0,1}|1[0-9]{2}|2[0-4][0-9]|25[0-5])(?:(?:\.(?:0|[1-9][0-9]{0,1}|1[0-9]{2}|2[0-4][0-9]|25[0-5])){0,2}\.?|(?:\.(?:0|[1-9][0-9]{0,1}|1[0-9]{2}|2[0-4][0-9]|25[0-5])){0,3}))$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:|(?:0|[1-9][0-9]{0,1}|1[0-9]{2}|2[0-4][0-9]|25[0-5])(?:(?:\\.(?:0|[1-9][0-9]{0,1}|1[0-9]{2}|2[0-4][0-9]|25[0-5])){0,2}\\.?|(?:\\.(?:0|[1-9][0-9]{0,1}|1[0-9]{2}|2[0-4][0-9]|25[0-5])){0,3}))$', 'gm')
const str = `
0
0.
0.0
0.0.
0.0.0
0.0.0.
0.0.0.0
0.0.0.0.
0.0.0.0.0
255.255.255.255
256.0.0.0
0.256`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}