#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)maps:google\.com\/maps\?q=(-?[0-9]+.[0-9]+),(-?[0-9]+.[0-9]+)"
Local $sString = "Date:X/X/XX" & @CRLF & _
"Time:XX:XX:XX" & @CRLF & _
"Speed:Xkm/h" & @CRLF & _
"Altitude:XX.Xm" & @CRLF & _
"Bat:XX%" & @CRLF & _
"maps:google.com/maps?q=YY.YYYYYY,-Z,ZZZZZZ" & @CRLF & _
"maps:google.com/maps?q=37.0625,-95.677068"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")