package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)maps:google\.com\/maps\?q=(-?[0-9]+.[0-9]+),(-?[0-9]+.[0-9]+)`)
var str = `Date:X/X/XX
Time:XX:XX:XX
Speed:Xkm/h
Altitude:XX.Xm
Bat:XX%
maps:google.com/maps?q=YY.YYYYYY,-Z,ZZZZZZ
maps:google.com/maps?q=37.0625,-95.677068`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}