#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "<pre>((?:[^<\s]\s?)*)</pre>"
Local $sString = "<pre>one</pre><p><b>two</b></p>\n<pre>DO NOT MATCH</pre><pre>BALLS</pre>"
Local $sSubst = "<p>$1</p>\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)