use strict;
my $str = '<pre>one</pre><p><b>two</b></p>\\n<pre>DO NOT MATCH</pre><pre>BALLS</pre>';
my $regex = qr/<pre>((?:[^<\s]\s?)*)</pre>/p;
my $subst = '<p>$1</p>\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";