package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<pre>((?:[^<\s]\s?)*)</pre>`)
var str = `<pre>one</pre><p><b>two</b></p>\n<pre>DO NOT MATCH</pre><pre>BALLS</pre>`
var substitution = "<p>$1</p>\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}