package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\s+([:;»!?/])|([«])\s+`)
var str = `Salut ! Ca va ?
« Comme un lundi » ; comme on dit...
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}