$re = '/\s+([:;»!?/])|([«])\s+/';
$str = 'Salut ! Ca va ?
« Comme un lundi » ; comme on dit...
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);